[HFCAC] Elevated Application Error Rate

Incident Report for MailForce Status

Resolved

Application exception rate has returned to normal levels.
Posted Jun 16, 2026 - 09:05 EDT

Investigating

We have detected an elevated application error rate (18 errors in the last 5 minutes). We are investigating.
Posted Jun 16, 2026 - 08:58 EDT
This incident affected: MailForce - HFCAC.