[HFCAC] Database Connectivity Issue

Incident Report for MailForce Status

Resolved

Database response times have returned to normal.
Posted Jun 16, 2026 - 08:59 EDT

Investigating

We are investigating a database connectivity issue.

Tracking ticket: IS-817
Posted Jun 16, 2026 - 08:58 EDT
This incident affected: MailForce - HFCAC.